1. Use vi to create a partition description
file by doing the following:
# vi /tmp/partitionfile
3
EFI 500MB
HPUX 100%
HPSP 400MB
2. Use ididsk to setup the disk partitioning using the
file created above:
# idisk -wf /tmp/partitionfile /dev/rdisk/disk15
# idisk -p /dev/rdisk/disk15
3.
Use vgcfgrestore to
restore lvm layout to new disk partition s2.
# vgcfgrestore -n /dev/vg00 /dev/rdisk/disk15
4.
Activate the volume
group again.
# vgchange -a y /dev/vg00
5.
Sync the mirrors and
verify everything is synced.
Do the "# vgsync /dev/vg00"
only the mirrors were not removed.
# vgsync /dev/vg00
# vgdisplay –v /dev/vg00
6.
Do the following for
each LVOL mirror on the bad disk removed.
# lvextend -m 1 /dev/vg00/lvol# /dev/disk/disk15
.... lvextend -m 1
(additional LV)...
7.
Use mkboot to format and
populate the newly created Extensible Firmware Interface (EFI) partition:
# mkboot -e -l /dev/rdisk/disk15
Files are copied from
/usr/lib/efi/....
8.
Update the lvol boot
path
# lvlnboot -R
# lvlnboot –v
9.
Use efi_ls to confirm
that the EFI partition is present and populated on the replaced disk:
# efi_ls -d /dev/rdisk/disk15
10.
Check the content of
AUTO file on EFI partition:
# efi_cp -d /dev/rdisk/disk15 -u
/EFI/HPUX/AUTO /tmp/x; cat /tmp/x
11.
Specify the -lq option
if you prefer that the system boots up without interruption in case of a disk failure:
# mkboot -a "boot vmunix -lq"
/dev/rdisk/disk15
12.
Set the boot option for
the alternate disk into EFI:
setboot –a 1/0/0/3/0.6.0
If you want it to be primary boot then:
setboot –p 1/0/0/3/0.6.0
13.
No comments:
Post a Comment