UnixPedia : HPUX / LINUX / SOLARIS: September 2013

Sunday, September 22, 2013

HPUX : NETTL LOG ARE NOT GETTING COLLECTED

Issue :

#-> /usr/sbin/netfmt -l -f /var/adm/nettl.LOG00

netfmt          Unable to open file '/var/adm/nettl.LOG00'. (208)
                open() returned error code : 2 - No such file or directory.
                Check input file name and try again.
Recommendation :
/usr/sbin/nettl –stop                                       // Restart nettle service                    
/usr/sbin/nettl -start
/usr/sbin/netfmt -l -f /var/adm/nettl.LOG00

HPUX : EXT_BUS LIMITATION ISSUE ON 11.23

it looks like we can see these disks/LUNs in ‘sar –d’ and ‘autopath display’ – yet 2 out of 4 paths can’t be seen in ‘xpinfo’ output and shows as NO_HW in ioscan.

We also seem to be having an issue with ext_bus limitation and the situation had been like this for at least couple of months now.

ext_bus 254  3/0/12/1/0/4/0.20.184.0.1    fcd_vbus CLAIMED     INTERFACE    FCP Array Interface
ext_bus 255  3/0/10/1/0/4/0.20.200.0.0    fcd_vbus CLAIMED     INTERFACE    FCP Array Interface
ext_bus 256  1/0/8/1/0/4/0.20.58.0.7               UNCLAIMED   UNKNOWN      FCP Array Interface
ext_bus 257  1/0/12/1/0/4/0.20.58.0.7              UNCLAIMED   UNKNOWN      FCP Array Interface
……
There are more than 255 ext_bus already. And might require a ioconfig reorg
Issue : as extn_bus has cross the limit of 255 limit, extn_bus number greater then 255 has been marked by kernal as no_hw, but IO request can be observe on device file in " sar -d 1 10 |grep -i <c?t?d? which is in no_hw status>

ext_bus     56  1/0/8/1/0/4/0.20.58.255.0         fcd_vbus  NO_HW       INTERFACE    FCP Device Interface
target      63  1/0/8/1/0/4/0.20.58.255.0.0       tgt       NO_HW       DEVICE
ctl         30  1/0/8/1/0/4/0.20.58.255.0.0.0     sctl      NO_HW       DEVICE       HP      OPEN-XP12000
ext_bus    146  1/0/8/1/0/4/0.20.86.0.0           fcd_vbus  NO_HW       INTERFACE    FCP Array Interface
ext_bus    147  1/0/8/1/0/4/0.20.86.255.0         fcd_vbus  NO_HW       INTERFACE    FCP Device Interface
target      36  1/0/8/1/0/4/0.20.86.255.0.0       tgt       NO_HW       DEVICE
ctl         64  1/0/8/1/0/4/0.20.86.255.0.0.0     sctl      NO_HW       DEVICE       HP      OPEN-XP12000
ext_bus    129  1/0/8/1/0/4/0.20.130.0.0          fcd_vbus  NO_HW       INTERFACE    FCP Array Interface
target      37  1/0/8/1/0/4/0.20.130.0.0.0        tgt       NO_HW       DEVICE
disk       1961  1/0/8/1/0/4/0.20.130.0.0.0.7      sdisk     NO_HW       DEVICE       HP      OPEN-V*3
ctl         33  1/0/12/1/0/4/0.20.218.255.0.0.0   sctl      NO_HW       DEVICE       HP      OPEN-XP12000
ext_bus     59  1/0/12/1/0/4/0.20.240.0.0         fcd_vbus  NO_HW       INTERFACE    FCP Array Interface
ext_bus     60  1/0/12/1/0/4/0.20.240.255.0       fcd_vbus  NO_HW       INTERFACE    FCP Device Interface
target     322  1/0/12/1/0/4/0.20.240.255.0.0     tgt       NO_HW       DEVICE
ctl         32  1/0/12/1/0/4/0.20.240.255.0.0.0   sctl      NO_HW       DEVICE       HP      OPEN-XP12000
ext_bus    259  3/0/12/1/0/4/0.20.251.255.0                 NO_HW       UNKNOWN      FCP Device Interface

Recommendation:
Need to look for possibility to release unsed extn_bus and reconfigure the ioconfig tree.
#Run the ioconfig_dump utility
/var/adm/crash/ioconfig/ioconfig_dump.exe
Create a new  ioconfig file called ioconfig.new.
## ioconfig_dump -w -o /tmp/ioconfig.new
Verify the instance mappings of the newly created ioconfig file
# ioconfig_dump -r  -o  /tmp/io.ascii.old
Total number of instances currently used:
# grep ext_bus /tmp/io.ascii.old|wc -l

#Backup /stand/ioconfig and /etc/ioconfig and copy ioconfig.new into both locations.
# cp /stand/ioconfig /stand/ioconfig.orig
# cp /etc/ioconfig /etc/ioconfig.orig
# cp /tmp/ioconfig.new /stand/ioconfig
# cp /tmp/ioconfig.new /etc/ioconfig
#shutdown -ry 0


Saturday, September 21, 2013

HPUX : HOW TO GENERATE A TEST EVENT ON CLIENT FOR HPSIM

Here is the command to run:
11.11: # /etc/opt/resmon/lbin/send_test_event disk_em

11.23/11.31: # /opt/sfm/bin/sfmconfig -t –a

HPUX : SIMPLE SCRIPT TO GET IMPORTANT INFO FROM SYSTEM TO COMPARE

Below script need to executed before server reboot

Make a executable file :
#cat >Data_pre.sh
Loggin=`logname`
export  DIR=/home/$Loggin/ 
cd $DIR
mkdir $DIR/todayaction2;cd todayaction2;parstatus >parstatus.pre_output;setboot -v >setboot.pre_output; \
bdf >bdf.pre_output;vparstatus >vparstatus.pre_output; \
sysdef > sysdef.pre_output; \
vgdisplay  -v >vgdisplay.pre_output; \
tail /var/adm/syslog/syslog.log > syslog.pre_output; \
ioscan >ioscan.pre_output;netstat -in >netstat.pre_output; \
cmviewcl -v >cmviewcl.pre_output;lanscan >lanscan.pre_output; \
ps -ef |grep -i pmon >oracle.pre_output;netstat -rn >netrpre_outpute.pre_output; \
swapinfo -tam >swap.pre_output; \
ps -efx >Porcess.pre_output; \
mount  -v   >mount-v-pre_output ; mount  -p >mount-p-pre_output ; \
lvlnboot -v >lvlnboot.pre_output ;ps -ef |grep -i horc > horc.pre_output; \
showmount -e >showmount-e-pre_output ; showmount -a >showmount-a-pre_output; \
uptime >uptime-pre_output ; vgdisplay -v >vgdisplay_pre_output; \
cp -p /etc/lvmtab /etc/lvmtab.`logname`.`date +%d-%m-%Y`.pre_output

tar -cvf  /home/$Loggin/Data_collectoin_`uname -n`_Before.tar /home/$Loggin/todayaction2
c /home/$Loggin/Data_collectoin_`uname -n`_Before.tar Data_collectoin_`uname -n`_Before.tar | mailx -m -s " Data_collectoin_`uname -n`_Before.tar " $Loggin@its.jnj.com


Below script need to executed After server reboot

Make a executable file :
#cat >Data_Post.sh       

Loggin=`logname`
export DIR=/home/$Loggin/ 
cd $DIR
mkdir $DIR/todayaction2;cd todayaction2;parstatus >parstatus.post_output;setboot -v >setboot.post_output; \
sysdef > sysdef.post_output; \
bdf >bdf.post_output;vparstatus >vparstatus.post_output; \
vgdisplay  -v >vgdisplay. post_output; \
tail /var/adm/syslog/syslog.log > syslog.post_output; \
ioscan >ioscan.post_output;netstat -in >netstat.post_output; \
cmviewcl -v >cmviewcl.post_output;lanscan >lanscan.post_output; \
ps -ef |grep -i pmon >oracle.post_output;netstat -rn >netrpre_outpute.post_output; \
swapinfo -tam >swap.posst_output; \
ps -efx >Porcess.post_output; \
mount  -v   >mount-v-post_output ; mount  -p >mount-p-post_output ; \
lvlnboot -v >lvlnboot.post_output ;ps -ef |grep -i horc > horc.post_output; \
showmount -e >showmount-e-post_output ; showmount -a >showmount-a-post_output; \
uptime >uptime-post_output ; vgdisplay -v >vgdisplay_post_output; \
cp -p /etc/lvmtab /etc/lvmtab.`logname`.`date +%d-%m-%Y`.post_output
tar -cvf  /home/$Loggin/Data_collectoin_`uname -n`_After.tar /home/$Loggin/todayaction2

uuencode /home/$Loggin/Data_collectoin_`uname -n`_After.tar Data_collectoin_`uname –n`_After.tar | mailx -m -s " Data_collectoin_`uname -n`_After.tar " $Loggin@its.jnj.com

IMPORTANT NOTE : PLEASE HASH THOSE LINE WHICH MAY HUNG YOUR SCRIPT, IF ANYTHING WRONG WITH SYSTEM

HPUX : HOW TO USE CPROP IN BLADE SYSTEM TO GATHER INFORMATION

/opt/propplus/bin/cprop -list >> cprop.txt
/opt/propplus/bin/cprop -detail -c "Memory Utilization"
/opt/propplus/bin/cprop -detail -c "System Summary"
/opt/propplus/bin/cprop -detail -c "Cooling"
/opt/propplus/bin/cprop -detail -c "Processors"
/opt/propplus/bin/cprop -detail -c "Firmware Information"
/opt/propplus/bin/cprop -detail -c "Cell Board"
/opt/propplus/bin/cprop -detail -c "Complex-wide Info"
/opt/propplus/bin/cprop -detail -c "Partition Information"
/opt/propplus/bin/cprop -detail -c "Memory"
/opt/propplus/bin/cprop -detail -c "Management Processor"
/opt/propplus/bin/cprop -detail -c "Power"
/opt/propplus/bin/cprop -detail -c "Temperature"
/opt/propplus/bin/cprop -detail -c "Voltage"
/opt/propplus/bin/cprop -detail -c "Disk Drive"
/opt/propplus/bin/cprop -detail -c "FC HBA"
/opt/propplus/bin/cprop -detail -c "IOTree"
/opt/propplus/bin/cprop -detail -c "Boot Device Configuration"
/opt/propplus/bin/cprop -detail -c "Crash Dump Configuration"
/opt/propplus/bin/cprop -detail -c "SCSI HBA"
/opt/propplus/bin/cprop -detail -c "Network Information"

/opt/propplus/bin/cprop -detail -c "Mem Error"

Tuesday, September 17, 2013

HPUX :VPAR IS SHOWING IN CRASH STATUS IN VPARSTATUS FOR LONG TIME

Issue : Vpar is showing in CRASH status in vparstatus for long time. When it was check on the console it waiting at prompt to generate partial dump as it could not able to generate complete. And even console is in hung state
#-> vparstatus
[Virtual Partition]
                                                                          Boot
Virtual Partition Name         State Attributes   Kernel Path             Opts
============================== ===== ============ ======================= =====
Vjupitor                      Crash Dyn,Auto,Nsr /stand/vmunix           -lq
Vpluto                          Up    Dyn,Auto,Nsr /stand/vmunix           -lq
[Virtual Partition Resource Summary]
                                CPU      Num   Num     Memory Granularity
Virtual Partition Name          Min/Max  CPUs  IO       ILM         CLM
==============================  =======  ====  ====  ==========  ==========

Vjupitor                         2/  6     6     6        1024        1024Vpluto                         2/  4     2     6        1024        1024
                                                  Memory (MB)
                                          ILM                     CLM
                                # User                  # User
Virtual Partition Name          Ranges/MB     Total MB  Ranges/MB     Total MB
==============================  ======================  ======================

Vjupitor                         0/   0         64831    0/   0             0Vpluto                         0/   0         24576    0/   0             0
--------Error at console------------
 P) The dump will be a PARTIAL dump:  24166 of 64796 megabytes.
    (A FULL dump is not possible.)
*** Enter your selection now.

*** A system crash has occurred. (See the above messages for details.)
*** The system is now preparing to dump physical memory to disk, for use
*** in debugging the crash.
*** The dump will be compressed.
*** To change this dump type, press any key within 10 seconds.
*** Proceeding with compressed dump
*** The dump will be a SELECTIVE dump:  11036 of 64796 megabytes.
*** To change this dump type, press any key within 10 seconds.
*** Select one of the following dump types, by pressing the corresponding key:
 S) The dump will be a SELECTIVE dump:  11036 of 64796 megabytes.
 P) The dump will be a PARTIAL dump:  24166 of 64796 megabytes.
    (A FULL dump is not possible.)
*** Enter your selection now.
------------------------------------------------
Recommended action :
RESET the console via XD and select option 3 “spft reset” and select partial dump generation option.


HPUX : TTYTYPE: COULDN'T OPEN /DEV/TTY FOR READING

Isssue :  Not able to assing tty.
====xdeadm@Pluto====
ttytype: couldn't open /dev/tty for reading
                                           stty: : Not a typewriter
 ======================================================================== This is a private computer facility. Access to it for any reason must be specifically authorized.  Unless you are  specifically authorized, your continued access and  further inquiry may expose you to criminal
and/or civil proceedings.
  =======================================================================
   Not a terminal                                                                                                                                             stty: : Not a typewriter
   stty: : Not a typewriter
Recommendation :
Restart the utmp demon the server.
/sbin/init.d/utmpd stop
/sbin/init.d/utmpd start
-----------
[root@Pluto:/var/adm/install-logs]
$ ps -ef |grep -i utmp
    root  6950     1  0 17:05:40 ?         0:07 /usr/sbin/utmpd
    root 26277 11564  1 17:32:03 pts/1     0:00 grep -i utmp
[root@ Pluto:/var/adm/install-logs]
$ date
Tue Sep 17 17:32:08 METDST 2013
[root@ Pluto:/var/adm/install-logs]

Saturday, September 14, 2013

HPUX : NOT ABLE TO DELETE THE QUEUE.

Issue : Printer queue on the server not able to delete it.
Error :
#-> cancel OCDRL0029
cancel: printer "OCDRL0029" was not busy
[root@ MARS:/.root]#
#-> lpadmin -xOCDRL0029
lpadmin: requests still queued for "OCDRL0029" -- use lpmove
[root@ MARS:/.root]#
#-> reject OCDRL0029
destination "OCDRL0029" will no longer accept requests
[root@ MARS:/.root]#
#-> lpadmin -xOCDRL0029
lpadmin: requests still queued for "OCDRL0029" -- use lpmove
Cause : Print job on the printer
#-> lpstat -oOCDRL0029
OCDRL0029-8990      rpuadm         priority 0  Aug  5 07:40
        00Hr9iE5.RPU                         5688 bytes
OCDRL0029-4805      rpuadm         priority 0  Aug  8 08:47
        00JI3SWf.RPU                         4350 bytes
OCDRL0029-6057      rpuadm         priority 0  Aug  8 10:59
        00JNrp7R.RPU                        24393 bytes
Need to cancel the pending job before deletion of the queue.

[root@ MARS:/.root]#
#-> cancel -e OCDRL0029
request "OCDRL0029-8990" cancelled
request "OCDRL0029-4805" cancelled
request "OCDRL0029-6057" cancelled
request "OCDRL0029-6088" cancelled
request "OCDRL0029-6144" cancelled
request "OCDRL0029-2223" cancelled
request "OCDRL0029-2244" cancelled
request "OCDRL0029-7754" cancelled
#-> lpadmin -xOCDRL0029
[root@MARS:/.root]#
Recommendation : cancel the pending job and then try to delete the queue.

NETBACKUP : NETBACKUP FS NOT RELEASING THE SPACE

Issue:

 

After Deleting the large log file from them system utilization of FS did not happen.

 

 

 

 

#/opt/atdd/bin/lsof /usr/openv/logs  # show large number of open file on the Filesystem it was happen due to removal of live file which do not got release by netbackup process.

 

 

 

Recommendation :

 

Bouncing of Netbackup application. Backup team restarted the NBU.

 

 

 

 

Friday, September 13, 2013

HPUX : Enabling Legacy Model.

          -L             Enable the legacy naming model.  This command

                          reinstalls the legacy I/O nodes and legacy device

                          special files which might have been removed with

                          rmsf -L (see rmsf(1M)).  When used with the -v

                          option, insf reports on whether legacy mode is

                          enabled or disabled.

Enable

#insf -v -L

 

Disable

#rmsf -L

 

HPUX : Configuring LAN Information for the MP

This section describes how to set and verify the server management processor (MP) LAN port

information. LAN information includes the MP network name, the MP IP address, the subnet mask,

and gateway address. This information is provided by the customer.

To set the MP LAN IP address:

1.    At the MP Main Menu prompt (MP>), enter cm.

2. From the MP Command Menu prompt (MP>CM:), enter lc (for LAN configuration).

The screen displays the default values and asks if you want to modify them. It is a good idea

to write down the information or log it to a file, because it may be required for future

troubleshooting.

Enter lc and press the Return key

 

 

3. NOTE: The value in the IP address field has been set at the factory. Obtain the LAN IP

address from the customer.

4. At the prompt, Do you want to modify the configuration for the customer

LAN?, enter Y.

The current IP address is shown; then the following prompt is displayed: Do you want to

modify it? (Y/[N])

5. Enter Y.

6. Enter the new IP address.

The customer provides this address for network interface 0.

7. Confirm the new address.

8. Enter the MP host name.

This is the host name for the customer LAN. The name can be up to 64 characters long and

can include alpha numerics, -dash (-), under score (_), period (.), or a space ( ). HP recommends

that the name be a derivative of the complex name, for example, Acme.com_MP.

9. Enter the LAN parameters for Subnet mask and Gateway address.

This information comes from the customer.

When this step is completed, the system will indicate that the parameters have been updated

and return to the MP Command Menu prompt (MP:CM>)

10. To check the LAN parameters and status, enter the ls command at the MP Command Menu

prompt (MP:CM>).

 

 

 

Monday, September 9, 2013

HPUX : Deactivate AUTO_VG_ACTIVATE in cluster aware Env


On node A and B are in cluster.

AUTO_VG_ACTIVATE=1 --Non cluster
AUTO_VG_ACTIVATE=0 -- Cluster Environment.

Both nodes have AUTO_VG_ACTIVATE=1  - this implies that ALL volume groups defined in the /etc/lvmtab are not part of a high availability cluster, “Cluster Aware”, and should be activated at boot (vgchange –a y /dev/vg_name).
   
  This is not the correct configuration for a volume group, that is “Cluster Aware”.  The Serviceguard package named “acms” uses /dev/vg04, /dev/vg04 has 27 logical volumes. The volume group activation, file system checks (fsck) and subsequent mounting/un-mounting of the file systems that reside on the logical volumes are all controlled by serviceguard package control script.
 
Your current configuration, at boot, tries to activate /dev/vg00, /dev/vg01 and /dev/vg04.
 
 
/etc/lvmrc should have  AUTO_VG_ACTIVATE=0  and the following custom_vg_activation stanza modified to include for non-Cluster Aware volume group activation, such as /dev/vg00 and /dev/vg01 –
 
Original custom_vg_activation stanza
________________________________________
#
 
custom_vg_activation()
{
        # e.g. /sbin/vgchange -a y -s
        #      parallel_vg_sync "/dev/vg00 /dev/vg01"
        #      parallel_vg_sync "/dev/vg02 /dev/vg03"
             
 
        return 0
}
 
#
______________________________________
 
Modified custom_vg_activation stanza
________________________________
 
#
 
custom_vg_activation()
{
        # e.g. /sbin/vgchange -a y -s
        #      parallel_vg_sync "/dev/vg00 /dev/vg01"
        #      parallel_vg_sync "/dev/vg02 /dev/vg03"
             
               /sbin/vgchange -a y /dev/vg00
              /sbin/vgchange -a y /dev/vg01
 
        return 0
}
 
#
____________________________________
 

The result of making this change is that /dev/vg00 and /dev/vg01 will be available at system boot, /dev/vg04 will not be available at system boot. The serviceguard package control script will make /dev/vg04 available when the acms package is started through serviceguard. 

Friday, September 6, 2013

HPUX : SAVE CRASH MANUALLY

Saving the dump manually
If the dump was not saved completely due to lack of space in the crash directory you have the possibility to save the dump again. The -r option (resave) need to be included when this is not the first time that savecrash runs.
# savecrash -v [-r] <crash directory>
There is also the possibility to save the dump directly to a DDS tape:
# savecrash -v [-r] -t /dev/rmt/0m

The crashconf(1M) command was enhanced to be able to configure dump compression:
# crashconf -c on
# crashconf -v
CLASS PAGES INCLUDED IN DUMP DESCRIPTION
-------- ---------- ---------------- ------------------------------
UNUSED 3645411 no, by default unused pages
USERPG 7113 no, by default user process pages
BCACHE 210990 no, by default buffer cache pages
KCODE 2670 no, by default kernel code pages
USTACK 264 yes, by default user process stacks
FSDATA 116 yes, by default file system metadata
KDDATA 68736 yes, by default kernel dynamic data
KSDATA 259004 yes, by default kernel static data
Total pages on system: 4194304
Total pages included in dump: 328120
Dump compressed: ON
DEVICE OFFSET(kB) SIZE (kB) LOGICAL VOL. NAME
------------ ---------- ---------- ------------ -----------------
31:0x03a000 310112 4194304 64:0x000002 /dev/vg00/lvol2
----------
4194304

Tuesday, September 3, 2013

HPUX : CONSOLE RESET VIA GSP


Issue : console got hung.

GSP is in hung status,

Recommendation :
failure of the GSP to communicate with the server internal I2C bus.  This will not affect server operations.
To reestablish this communication link log into the GSP, run the command "xd" then select option "3"


 
 

Monday, September 2, 2013

HPUX :Business volume copy script sync and split is not working, permission issue.


Issue: Business volume copy script sync and split is not working, is logs below message. indicating
problem with authenticatoin.


[root@jupiterA:/var/adm/ExSID_PJ6/DB/exsid.09-02-2013_09-55-25]#
#-> more exsid.log
Warning: Permanently added 'dbcitx6,xxx.xxx.xxx.xxx' (ECDSA) to the list of known h
########################################################################
#                                                                      #
#                          WARNING NOTICE:                             #
#  "You are about to enter a Private Network that is intended for the  #
#  authorized  use of a Private  Company and its affiliate  companies  #
#  (the "Company") for business purposes only. The actual or attempted #
#  unauthorized access,use or modification of this network is strictly #
#  prohibited by the Company. Unauthorized users  and/or unauthorized  #
#  use are subject to Company disciplinary proceedings and/or criminal #
#  and  civil penalties in  accordance  with applicable  domestic and  #
#  foreign laws. The use of this system may be monitored and recorded  #
#  for administrative and security reasons. If such monitoring and/or  #
#  recording  reveals possible  evidence of  criminal  activity,  the  #
#  Company may provide the monitored evidence of such activity to law  #
#  enforcement officials."                                             #
#                                                                      #
########################################################################

WARNING: Your password has expired.
Password change required but no TTY available.
Warning: Permanently added 'dbcitx6,xxx.xxx.xxx.xxx' (ECDSA) to the list of known hosts.
########################################################################
#                                                                      #
#                          WARNING NOTICE:                             #
#  "You are about to enter a Private Network that is intended for the  #
#  authorized  use of a Private  Company and its affiliate  companies  #
#  (the "Company") for business purposes only. The actual or attempted #
#  unauthorized access,use or modification of this network is strictly #
#  prohibited by the Company. Unauthorized users  and/or unauthorized  #
#  use are subject to Company disciplinary proceedings and/or criminal #
#  and  civil penalties in  accordance  with applicable  domestic and  #
#  foreign laws. The use of this system may be monitored and recorded  #
#  for administrative and security reasons. If such monitoring and/or  #
#  recording  reveals possible  evidence of  criminal  activity,  the  #
#  Company may provide the monitored evidence of such activity to law  #
#  enforcement officials."                                             #
#                                                                      #
########################################################################

WARNING: Your password has expired.
Password change required but no TTY available.
Warning: Permanently added 'dbcitx6,xxx.xxx.xxx.xxx' (ECDSA) to the list of known h
########################################################################


Recommended action: 

Check the account status of the account involve in the script.
Here Root password got expired and causing the script to failed to create the directory on the primary node.

HPUX : UX:vxfs mount: ERROR: V-3-24996: Unable to get disk layout version

Issue :

After system reboot vg failed to activate , manual activation show system is failed to query  the disk. ioscan show the disk status are claimed and available on the system.

Error :

mountall: cannot mount /dev/vg_edwpsw/orasw01_11g
mountall: diagnostics from mount
UX:vxfs mount: ERROR: V-3-20003: Cannot open /dev/vg_edwpsw/orasw01_11g: No such device or address
UX:vxfs mount: ERROR: V-3-24996: Unable to get disk layout version
mountall: cannot mount /dev/vg_edwpsw/orasw01
mountall: diagnostics from mount
UX:vxfs mount: ERROR: V-3-20003: Cannot open /dev/vg_edwpsw/orasw01: No such device or address
UX:vxfs mount: ERROR: V-3-24996: Unable to get disk layout version
mountall: cannot mount /dev/vg_edwpsw/lv_apps
mountall: diagnostics from mount
UX:vxfs mount: ERROR: V-3-20003: Cannot open /dev/vg_edwpsw/lv_apps: No such device or address
UX:vxfs mount: ERROR: V-3-24996: Unable to get disk layout version

[root@jupiterA:/etc/lvmconf]#
#-> grep -i "Wrong disk" /var/adm/syslog/syslog.log
Sep  1 16:42:42 jupiterA vmunix: LVM: VG 64 0x080000: PVLink 1 0x00009f Attach failed. Wrong disk!
Sep  1 17:14:45 jupiterA vmunix: LVM: VG 64 0x080000: PVLink 1 0x00009f Attach failed. Wrong disk!
Sep  1 17:14:45 jupiterA vmunix: LVM: VG 64 0x080000: PVLink 1 0x0000a6 Attach failed. Wrong disk!
Sep  1 17:14:45 jupiterA vmunix: LVM: VG 64 0x080000: PVLink 1 0x00011e Attach failed. Wrong disk!
Sep  1 17:14:45 jupiterA vmunix: LVM: VG 64 0x080000: PVLink 1 0x00011f Attach failed. Wrong disk!
Sep  1 17:15:13 jupiterA vmunix: LVM: VG 64 0x080000: PVLink 1 0x0000a6 Attach failed. Wrong disk!
[root@jupiterA:/etc/lvmconf]#


Recommendation Action :

Restore the vg cofinguration on the Disk , after verifying the disk and VG association.

#-> vgcfgrestore -f vg_edwpsw.conf.old -l
Volume Group Configuration information in "vg_edwpsw.conf.old"
VG Name /dev/vg_edwpsw
 ---- Physical volumes : 4 ----
       /dev/rdisk/disk149 (Non-bootable)
       /dev/rdisk/disk156 (Non-bootable)
       /dev/rdisk/disk276 (Non-bootable)
       /dev/rdisk/disk277 (Non-bootable)


vgcfgrestore  -f /etc/lvmconf/vg_edwpsw.conf.old /dev/rdisk/disk149
vgcfgrestore  -f /etc/lvmconf/vg_edwpsw.conf.old /dev/rdisk/disk156
vgcfgrestore  -f /etc/lvmconf/vg_edwpsw.conf.old /dev/rdisk/disk276
vgcfgrestore  -f /etc/lvmconf/vg_edwpsw.conf.old /dev/rdisk/disk277

[root@jupiterA:/home/ssingh45]#
#-> vgimport -sN -m vg_edwpsw.mapfile.ssingh45 vg_edwpsw
vgimport: Quorum not present, or some physical volume(s) are missing.
vgimport: Volume group "/dev/vg_edwpsw" has been successfully created.
Warning: A backup of this volume group may not exist on this machine.
Please remember to take a backup using the vgcfgbackup command after activating the volume group.

vgcfgrestore command not able to resolve the issue, finally it was decided to re-create the VG with new set of Disk as , old set of disk are always are problematic , after reboot and maintenance.

Size of disk in conf and in diskscan are different which causing the conflict. it seems something messy how it was happen. no clue , might someone imported with wrong mapfile.

#-> vgcfgrestore -vl -n vg_edwpsw
Volume Group Configuration information in "/etc/lvmconf/vg_edwpsw.conf"
VG Name /dev/vg_edwpsw
 ---- Physical volumes : 4 ----
      PV         Type         Size (kb)          Start (kb)   PVkey
     disk149   Non-Boot      104857920          21184        2
     disk156   Non-Boot      104857920          21184        3
     disk276   Non-Boot       39846720          21184        4
     disk277   Non-Boot       39846720          21184        5

max_pv 255  max_pe 10000 max_lv 255 vg_version 1.0


SCSI describe of /dev/rdisk/disk149:
             vendor: HP
         product id: OPEN-V
               type: direct access
               size: 39846720 Kbytes
   bytes per sector: 512
SCSI describe of /dev/rdisk/disk156:
             vendor: HP
         product id: OPEN-V
               type: direct access
               size: 39846720 Kbytes
   bytes per sector: 512
SCSI describe of /dev/rdisk/disk276:
             vendor: HP
         product id: OPEN-V
               type: direct access
               size: 104857920 Kbytes
   bytes per sector: 512
SCSI describe of /dev/rdisk/disk277:
             vendor: HP
         product id: OPEN-V
               type: direct access
               size: 104857920 Kbytes
   bytes per sector: 512



HPUX : SWINSTALL :PERMISSION ISSUE WHILE INSTALLING THE PRODUCT.

Issue :

while installation of the product below error enter in swinstall, related the permssion issue on the depot.


--------------
  08/15/13 03:04:08 EDT  BEGIN swinstall SESSION
         (non-interactive) (jobid=jupiterA-0158)

       * Session started for user "root@jupiterA".

       * Beginning Selection
       * Target connection succeeded for "jupiterA:/".
ERROR:   "jupiterA:/home/averma10/idmsnags.hpux.depot":  You do not
         have permission for this operation.  The depot owner, system
         administrator, or alternate root owner may need to use the
         "swreg" or "swacl" command to give you permission.  Or, to
         manage applications designed and packaged for nonprivileged
         mode, see the "run_as_superuser" option in the "sd" man page.
       * Source connection failed for
         "jupiterA:/home/averma10/idmsnags.hpux.depot".
WARNING: More information may be found in the daemon logfile on this
         target (default location is
         jupiterA:/var/adm/sw/swagentd.log).
       * Selection had errors.



=======  08/15/13 03:04:10 EDT  END swinstall SESSION (non-interactive)
         (jobid=jupiterA-0158)


Reccommeded action :

Above error indicate depot is not register.

[root@jupiterA:/var/adm/install-logs]#
#-> swreg -l depot /home/averma10/idmsnags.hpux.depot

=======  09/02/13 08:38:09 EDT  BEGIN swreg SESSION (non-interactive)

       * Session started for user "root@jupiterA".

       * Beginning Selection
       * Targets:                jupiterA
       * Objects:                /home/averma10/idmsnags.hpux.depot
       * Selection succeeded.



=======  09/02/13 08:38:09 EDT  END swreg SESSION (non-interactive)

[root@jupiterA:/var/adm/install-logs]#
#-> swlist -l depot
# Initializing...
# Target "jupiterA" has the following depot(s):
  /var/opt/mx/depot11
  /tmp/ident/itsgimgia11-31-042011
  /tmp/idmsnags.hpux.depot
  /home/averma10/idmsnags.hpux.depot

 
Regristratoin of the depot resolve the prermission issue on the depot and this time installation of the
product went fine.