UnixPedia : HPUX / LINUX / SOLARIS: HPUX : Matching Error Messages to Physical Disks and Volume Groups

Saturday, October 11, 2014

HPUX : Matching Error Messages to Physical Disks and Volume Groups



Often an error message contains the device number for a device, rather than the device file name.
For example, you might see the following message in
/var/adm/syslog/syslog.log:
Asynchronous write failed on LUN (dev=0x3000015)
IO details : blkno : 2345, sector no : 23

To map this error message to a specific disk, search under the /dev directory for a device file
with a device number that matches the printed value. More specifically, search for a file whose
minor number matches the lower six digits of the number following dev:. The device number in
this example is 3000015; its lower six digits are 000015, so search for that value using the
following command:
# ll /dev/*dsk | grep 000015
brw-r----- 1 bin sys 3 0x000015 May 26 20:01 disk43
crw-r----- 1 bin sys 23 0x000015 May 26 20:01 disk43
Use the pvdisplay command to determine which volume group contains this physical volume as
follows:
# pvdisplay /dev/disk/disk43 | grep "VG Name"
VG Name /dev/vgtest
If the pvdisplay command fails, search for the physical volume in the LVM configuration files
/etc/lvmtab and /etc/lvmtab_p as follows:
# lvmadm -l -V 1.0
--- Version 1.0 volume groups ---
VG Name /dev/vg00
PV Name /dev/disk/disk36_p2
VG Name /dev/vgtest
PV Name /dev/disk/disk43
VG Name /dev/vg03
PV Name /dev/dsk/c2t2d0
If your version of lvmadm does not recognize the –l option, use the strings command as follows:
# strings /etc/lvmtab | more
/dev/vg00
/dev/disk/disk36_p2
/dev/vgtest
/dev/disk/disk43
/dev/vg03
/dev/dsk/c2t2d0
Based on the output of these commands, the error message refers to physical volume /dev/disk/disk43,
 which belongs to volume group vgtest.
Similarly, some LVM error messages in /var/adm/syslog/syslog.log contain the device
number for a volume group. For example:

LVM: VG 128 0x002000: Lost quorum.

The major number 128 indicates that this is a Version 2.x volume group. A Version 1.0 volume
group has a major number of 64. To map this error message to a volume group, search under the
/dev directory for a volume group device file with a device number that matches the major and
minor numbers. In this example, the major number is 128 and the minor number is 0x002000,
so search for those value using the following command:
# ll /dev/*/group | grep 128.0x002000
crw-r----- 1 root sys 128 0x002000 Jan 7 08:27 /dev/vgtest2/group

No comments:

Post a Comment