UnixPedia : HPUX / LINUX / SOLARIS: How to create a secondary boot disk

Friday, January 18, 2013

How to create a secondary boot disk


Note: This will create an identical copy of the current vg00. The
      new volume group needs to as big as vg00. This will also be a static
      version of the primary boot disk which could be use in case of
      problem.

      Note: The following example is using the disk c1t6d0 and the
      volume group vg01

      1) Initialize the disk and make it bootable
           pvcreate -B /dev/rdsk/c1t6d0
           Note: the -B parameter tells pvcreate that this will be a bootable
           disk.
           mkboot /dev/dsk/c1t6d0
           mkboot -a "hpux" /dev/rdsk/c1t6d0
      2) Create the volume group
           mkdir /dev/vg01
           mknod /dev/vg01/group c 64 0x010000
           vgcreate /dev/vg01 /dev/dsk/c1t6d0
      3) Find the size of each logical volume in vg00
           vgdisplay -v /dev/vg00 | more
           look at LV Size (Mbytes) for each logical volume and note it.
           Note: this example will use these value:
                lvol1 84M
                lvol2 256M
                lvol3 140M
                lvol4 500M
                lvol5 64M
                lvol6 20M
                lvol7 500M
                lvol8 500M

         Note: The size of the new logical volumes needs to be exactly the
         same as the size of the logical volumes on the primary root disk.
      4) Create the first 3 logical volumes contiguous (needed by the system)
            lvol1:
                lvcreate -L 84 -C y -r n /dev/vg01
            lvol2:
                lvcreate -L 256 -C y -r n /dev/vg01
            lvol3:
                lvcreate -L 140 -C y -r n /dev/vg01
      5) Now create the other logical volumes
            lvol4:
                lvcreate -L 500 /dev/vg01
            lvol5:
                lvcreate -L 64 /dev/vg01
            lvol6:
                lvcreate -L 20 /dev/vg01
            lvol7:
                lvcreate -L 500 /dev/vg01
            lvol8:
                lvcreate -L 500 /dev/vg01
        6) Copy each logical volume except the swap which is usually lvol2.
            dd if=/dev/vg00/rlvol1 of=/dev/vg01/rlvol1 bs=1024k
            dd if=/dev/vg00/rlvol3 of=/dev/vg01/rlvol3 bs=1024k
            dd if=/dev/vg00/rlvol4 of=/dev/vg01/rlvol4 bs=1024k
            dd if=/dev/vg00/rlvol5 of=/dev/vg01/rlvol5 bs=1024k
            dd if=/dev/vg00/rlvol6 of=/dev/vg01/rlvol6 bs=1024k
            dd if=/dev/vg00/rlvol7 of=/dev/vg01/rlvol7 bs=1024k
            dd if=/dev/vg00/rlvol8 of=/dev/vg01/rlvol8 bs=1024k
        7) Verify the integrity of all the new volume except swap.
            Note: The following lines are base on a system with vxfs
            filesystems except for /stand (lvol1) which needs to be hfs.
            fsck -F hfs /dev/vg01/rlvol1
            fsck -F vxfs /dev/vg01/rlvol3
            fsck -F vxfs /dev/vg01/rlvol4
            fsck -F vxfs /dev/vg01/rlvol5
            fsck -F vxfs /dev/vg01/rlvol6
            fsck -F vxfs /dev/vg01/rlvol7
            fsck -F vxfs /dev/vg01/rlvol8
        8) Now configure the Boot Data Reserved Area (BDRA)
           Note: The following commands assume that /stand is lvol1,
           swap is lvol2 and / is lvol3
            lvlnboot -b /dev/vg01/lvol1 /dev/vg01
            lvlnboot -r /dev/vg01/lvol3 /dev/vg01
            lvlnboot -s /dev/vg01/lvol2 /dev/vg01
            lvlnboot -d /dev/vg01/lvol2 /dev/vg01
        9) Modify the fstab file on the new disk.
            a) If /tmp_mnt doesn't exist create it
               mkdir /tmp_mnt
            b) Mount the new root filesystem on /tmp_mnt
               mount /dev/vg01/lvol3 /tmp_mnt
            c) change to etc directory on the new disk.
               cd /tmp/etc
            d) Modify all occurence of vg00 in the fstab for vg01
               sed "s/vg00/vg01/" fstab > fstab.out
               mv fstab fstab.BAK
               mv fstab.out fstab
            e) Unmount the new root filesystem
               cd /
               umount /tmp_mnt

No comments:

Post a Comment